LaTeX: risolvere il warning “PDF inclusion: found PDF version <1.5>, but at most version <1.4> allowed”

Ultimamente sto usando LaTeX per scrivere la mia tesi di laurea. Dopo aver inserito alcune immagini in formato PDF, il “compilatore” pdflatex si lamenta del fatto che la versione PDF specificata nel file di tali immagini era troppo avanzata (1.5), e che la massima versione ammessa è la 1.4 con questo warning:

“PDF inclusion: found PDF version <1.5>, but at most version <1.4> allowed”

Tuttavia questo è solo un warning, infatti le immagini sono regolarmente comparse nel documento. Ma come si può evitare che questo venga presentato?

Basta aggiungere un’istruzione nel preambolo che specifichi a pdflatex di consentire anche la versione PDF 1.5 in questo modo:

\documentclass[a4paper,11pt,twoside]{article}
<preambolo>
\pdfoptionpdfminorversion=5
\begin{document}
<immagini>
\end{document}

In questo modo pdflatex non genererà più warnings.

Leave a Reply

Your email address will not be published. Required fields are marked *